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SOLUTION WALK-THROUGH AND PLUGIN EXAMPLE 

GOAL 

Understand and explore a working LabVIEW application that combines multiple design patterns that we will 

explore individually in later exercises. 

SCENARIO 

This application is a high-level UI framework that calls into an arbitrary number of plugins.  The plugins could be 

performing any number of tasks, including data acquisition tasks or general visualizations.  The architecture is such 

that separate developers could work on different sections of the application without interfering with one another 

thanks to established APIs.  In this first exercise we will change the set of plugins that are loaded by the framework 

dynamically. 

CONCEPTS COVERED 

 Overview of application for demonstration 

 Dynamic selection of plugins 

SETUP 

 Open the ‘UI Plugin Solution.lvproj’ from the UI Plugin Framework Solution Folder 

 Launch ‘main.vi’ and click Run 

 Ensure that the menu options show and launch correctly 

 Press ‘Stop’ to terminate the application  
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1. Explore the application’s functionality 

a. Click the Run VI button 

b. Click the Menu Button in the bottom left to show the menu 

 

c. The list in the menu is populated as a result of plugins that are detected and installed.  Later in 

this exercise you will change the plugins that are running without restarting the application.  In 

the exercise titled ‘Factory Method Design Pattern (Creating a Plugin)’ you’ll see how to create 

and install a plugin for this application using a standard factory design pattern. 

d. Use the mouse to click and drag up and down on the menu.  Point out that they’re looking at a 

reusable UI component that has been built using an XControl and was designed for use on a 

touch-screen. 

 

e. Click on Sound and Vibration, and explain that this is going to run one on the plugins.  

NOTE: As this is a demonstration, many of the other plugins are not functional and may not display a UI. This does 

not negatively impact the ability to operate or use the rest of the application. 

2. Demonstrate that the framework can communicate with plugins 

a. Click the Menu Button to open the menu.  The showing plugin receives a message when the 

menu appears, giving the plugin the option of performing a task.  In this case, opening the menu 

pauses the acquisition to conserve resources.  Clicking the button again closes the menu and 

send a message to the plugin, which then opts to resume the acquisition. 

b. As we will see later on, all of these plugins are atomic, self contained applications that can be 

developed and modified independently of the calling framework. 

3. Load different plugins during run-time 
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a. Click the Load button in the bottom left corner to open a file dialog that allows you to select the 

location on disk of new plugins. The default location should be the root where all of these demos 

are located.   

b. Navigate into the folder entitled ‘Plugin Libraries.’ Choose from any of the other available 

libraries and select Current Folder in the bottom right corner. 

c. Notice that the responsiveness of the UI is not affected while the new plugins are being loaded 

into memory. 

d. After a few moments, a different set of plugins should be shown in the menu. 

4. Show the Block Diagram 

a. Stop the application by clicking ‘Stop’ 

b. Switch to the block-diagram by pressing CTRL+E 

c. This application communicates amongst multiple parallel processes using a combination of 

producer consumer loops, queued state machines and a factory pattern.  This code is built using 

LabVIEW objects, so some elements may not be immediately recognized, but the same 

underlying principles apply and we’ll look at both an OO and non-OO implementation. 
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PRODUCER CONSUMER QUEUED STATE MACHINE WITHOUT CLASSES 

GOAL 

This exercise will illustrate an alternate implementation of the UI Framework that does not use classes.  It’s a 

simple and quick demo to bridge to the object oriented example and demonstrate some of the potential 

drawbacks of the classic enum/variant method to passing data. 

SCENARIO 

Clicking on a menu item invokes the ‘toggle menu’ item command, but enqueues the wrong data type, creating a 

run-time error. 
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1. Introduce alternative implementation without classes 

a. Open the Project entitled ‘UI Framework (PC-QSM).lvproj’ in the ‘UI Framework (PC-QSM)’ 

Folder. 

b. Open main.vi and switch to the block diagram, which uses messages built with enums and 

variants.  The application is functionally equivalent, but it poses some additional risk due to the 

lack of data encapsulation. 

c. This framework will call into and run the same plugins as the one explored in the previous 

exercise. 

d. Switch to the front panel and run the application to illustrate that it works. 

2. Generate a run-time error 

a. Open the menu by clicking on the button in the bottom left, this is enqueing a message to the UI 

Display control state machine to run the toggle menu command. 

b. This command also gets run when a menu item is clicked on; however, the message to toggle the 

menu has been composed incorrectly in the “Sliding Menu XControl”: Value Change case.  

Instead of a Boolean data type, it uses an integer. As a result, clicking on a menu item will send 

an incorrect datatype at run-time, which cases an error. 

 

c. This can be avoided by encapsulating data with classes. 

3. Examine the source of the error, as shown below: 
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STATE PATTERN FOR QUEUED MESSAGE HANDLING 

GOAL 

LabVIEW Classes provide an alternative implementation of what is typically referred to as a queue-driven state 

machine for dispatching and executing commands.  By representing the commands with a class hierarchy, we can 

utilize encapsulation to ensure that data types are enforced at compilation and make it possible to add new 

commands without modifying the calling code. 

SCENARIO 

In the first part of this exercise, we will execute an existing command by invoking the send method.   

CONCEPTS COVERED 

 Class hierarchy window 

 Inheritance 

 Dynamic Dispatch 

 Accessor Methods 
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PART ONE: SENDING A MESSAGE 

4. Explore the command hierarchies for both the UI and Plugin State Machines 

a. Navigate to the folder ‘UI Framework Exercises, and open ‘UI Framework Exercises.lvproj.’ 

b. This application has two separate class hierarchies that are used in separate command patterns. 

Expand ‘Framework SubVIs > User Interface > UI Command Manager’ to show the class hierarchy 

for the UI Command state machine.  

 

a. Expand the contents of ‘UI Command Manager.lvclass.’ This is the parent class for all commands 

for the UI State Machine.  It contains two methods and no data.  The methods are Send 

Command.vi and Execute Command.vi.  ‘Send Command.vi’ is a static method we will use to 

enqueue child classes and we will override ‘Execute Command.vi’ to customize the behavior of all 

the child classes. 

 

b. Right-click on UI Command Manager.lvclass and select ‘Show Class Hierarchy’ to illustrate that 

this is the parent class and that all the other commands inherit and from it. 
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c. Navigate to the block diagram of main.vi.  The loop labeled ‘User Interface Display Control’ de-

queues objects from this class hierarchy and runs the appropriate version of Execute 

Command.vi. 

 

d. Double-click on Execute Command.vi.  Unlike a normal subVI, this subVI is dynamically 

dispatched, which means the run-time engine decides which version of ‘execute command.vi’ to 

run based on the object that is sent to the dynamic terminal.  As a result, double-clicking on the 

VI brings up a menu that lists all the instances of ‘Execute Command.vi’ that could potentially be 

run during execution.   
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a. Double-click on the first item in the list, which is the copy of ‘Execute Command.vi’ belonging to 

the parent, UI Command Manager.lvclass. View the connector pane of this icon and right-click on 

the input terminal for the object.  When a VI belongs to a class hierarchy, you can specificy that 

the input terminal for the class is a Dynamic Dispatch Input, which enables children to override 

this VI.  Navigate to the options for ‘This Connection Is’ and ensure that ‘Dynamic Dispatch Input’ 

has been selected.  Verify that the input terminal is set to Dynamic Dispatch Input (Required). 

 

5. Send a command to ‘Toggle Menu’ when a user selects a menu item 

a. Return to the front panel of main.vi and run the application. 

b. Click on the menu button to expand the list of plugins. Clicking on one of these items displays 

that plugin’s front panel in the subPanel, but we currently have to go and manually click the 

menu button to collapse this list.  To automatically close the menu after a user has selected a 

plugin, we’re going to dispatch an instance of ‘Menu Toggle Command.lvclass’ to the UI Interface 

Display Control. 

c. Stop the application and switch to the block diagram. 
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d. Navigate to the case in the Event Structure labeled “Sliding Menu XControl”: Value Change.”  

This case currently handles a user selecting an item from the menu and sends the command to 

display the appropriate plugin based on the updated value of the control. 

 

e. Open the Project Explorer and navigate to ‘Framework SubVIs > User Interface > UI Command 

Manager > UI Command Manager.lvclass.’  We will be using ‘send command.vi’ to enqueue an 

instance of ‘Menu Toggle Command.lvclass.’  Perform the following steps to implement the new 

command as shown: 

1. Drag and drop a copy of Send Command.vi to the block diagram 

2. Drag and drop a copy of Menu Toggle Command.lvclass to the block diagram  

3. Connect the wire from the object to the input terminal of Send Command.vi 

4. Connect the error wires 

 

f. Return to the front panel of main.vi and click the run button.  Expand the menu and show that 

selecting an item now closes the menu. 
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PART TWO: CREATING A NEW COMMAND 

1. Create a new command to set the header of the display to show the name of the plugin that is running. 

Note: It’s important to realize that this task will be accomplished without modifying the top level VI 

a. In the LabVIEW Project Explorer, navigate to and expand ‘Framework SubVIs > User interface.’  

The list of classes shown represents the commands that have currently been implemented. 

 

b. Right click on the ‘User Interface’ Folder and select ‘New > Class.’ When prompted, select the 

title ‘Set Header Text Command’ and click OK. The new class will appear in the Project Explorer. 

c. To function properly as a command, this class will need to inherit the capabilities of the ‘UI 

Command Manager’ class.  To specify this relationship, right click ‘Set Header 

TextCommand.lvclass’ and select Properties. 

d. In the Properties Dialog that appears for this class, select Inheritance from the list of Categories.  

On the right side of the screen, select Change Inheritance. 

 

e. The ‘Change Inheritance’ dialog will appear, which lists all of the Classes currently loaded in the 

Project Explorer.  Find and select ‘UI Command Manager.lvclass,’ and click Inherit from Selected. 
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f. The Change Inheritance dialog will close, returning to the Class Properties dialog.  Click OK to 

save the changes. 

g. The new class will contain a control where the data members can be defined.  Double click on the 

control, ‘Set Header Text Command.ctl’ 

h. In the data cluster for the class, put a new string control and name it ‘Header Text.’  This will be 

the private data that only this command has access to. 

 

i. Before proceeding, ensure that the new ‘Set Header Text Command.lvclass’ class has been saved 

to disk.  A folder has already been created where it should be saved, here: ‘UI Framework 

Exercises\Framework SubVIs\User Interface\UI Command Manager\UI Set Header Text.’  To do 

this, return to the Project Explorer and click the toolbar icon for ‘Save All,’ as shown below:  
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j. Return to the front panel for ‘Set Header Text Command.ctl.’  Right click on the border of the 

string control and select the option to Create Accessor, as shown.  This may take a moment, but 

it will generate wrapper VIs that allow us to set and read this control value. 

 

k. A configuration dialog will appear, prompting us to specify which methods we want to create.  

Select ‘Read and Write’ from the drop-down, ensure ‘Create static accessor’ is selected, and 

press ‘Create’. Two new VIs should now appear in the Project Explorer as shown: 
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l. The final step is to create the new copy of Execute.vi, which will be run by the state machine 

when this command is called.  Right click on the ‘Set Header Text Command.lvclass’ and select 

‘New > VI for Override.’ 

m. In the dialog that appears, select ‘Execute Command.vi.’ LabVIEW will generate a VI as shown at 

the top of the image below.  Make the necessary changes to implement the state’s functionality.  

An example is shown at the bottom of the image.  The following are the recommended steps to 

build it: 

i. Delete the subVI in the generated code (parent copy of Execute Command.vi) 

ii. Reconnect the User Interfaces References Wire 

iii. Place an ‘Unbundle by Name,’ wire in the User Interfaces References and select ‘Header 

text’ reference 

iv. Place the accessor created in previous steps to read the header text, ‘Read Header 

Text.vi’ onto block diagram and wire according to image below. 

v. Wire a False constant into the Stop Indicator 

vi. Wire the reference to the header text to the property node 

vii. Wire the output of ‘Read Header Text.vi’ to the value of the property node 

 

n. Once again, save everything and close the windows that are currently open. 

o. Finally, we must call this command from the appropriate location as we did in the earlier 

example for the toggle menu command.  In this case, we will call it when the plugin handler 
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receives a request to load a plugin.  Navigate to ‘Framework SubVIs > Plugin Handler > Plugin 

Display UI.lvclass > Execute.vi.’ 

p. On the block diagram, scroll to the location where this command will be sent from, as shown 

below: 

 

q. Build the command by implementing the following code 

 

NOTE: Be sure that the static copy of ‘Send Command.vi’ is the method belonging to the parent class, ‘UI 

Command Manager.lvclass,’ as shown in the following image: 
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r. Save all the changes and open and run main.vi.  When a plugin is clicked, the header will now be 

populated with the same string that is used to identify the plugin in the menu. 
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FACTORY METHOD DESIGN PATTERN (CREATING A PLUGIN) 

GOAL 

‘Factory Method Pattern’ refers to a well-know object-oriented pattern for creating objects at run-time.  These 

objects are typically derived from a parent, and they extend the functionality for the specific object through the 

use of inheritance. 

SCENARIO 

We have an application that runs and displays applications that are loaded at run-time as plugins.  In this case, the 

plugins typically consist of a user interface that allows the user to perform an arbitrary and independent task.  

After running the plugin framework, the menu displays the names of all the plugins that were found on disk.  

Clicking on any item displays the front panel and sends a message to the plugin that its user interface is showing.  

In this scenario, we want to take a simple data acquisition application and turn it into a plugin that this application 

can run and load. 

DESCRIPTION 

The VI that we want to use in the plugin has already been created.  In this demonstration, the VI will be added to a 

new object we create such that it will be launched by the framework.  The framework will send user events to the 

plugin for communication purposes.  After registering these events with the plugin, we will be able to understand 

and act upon these events. 

CONCEPTS COVERED 

 Dynamically loading classes 

 Defining and creating a new child of a class hierarchy 

SETUP 

 The plugin that we will require uses the DAQmx API. Make sure it is installed 

 Ensure a device (Dev0) has been simulated and appears as shown below in Measurement Explorer.    
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1. Introduce the Plugin Template Class 

a. From the root of this hands-on, open ‘Project Libraries> Measurement Tasks’ and launch the 

Plugins.lvproj to see the Project Explorer containing all the plugins. 

b. Navigate to ‘Parent Plugin Definition > Plugin Template > Generic Plugin.’  

c. Right-click on ‘Generic Plugin.lvclass’ and select Show Class Hierarchy.  This illustrates that all the 

plugins currently running in the framework are children of this generic plugin definition.  Close 

this window. 

d. The class, ‘Generic Plugin.lvclass’ contains all the private and public methods that are called by 

the framework to interact with a plugin.  Some of them can be overridden to customize the 

behavior of a plugin, such as the run and stop functionality. 

 

2. Introduce the application that we will be creating a plugin from 

a. A simple data acquisition application is included in the Plugins project for the sake of creating a 

new plugin.  In the Project Explorer, navigate to the folder labeled ‘DAQ’ and you should see a vi 

entitled ‘Acquire Data.vi’ 

 

b. Close the UI Plugin Framework Project and any other open projects that call these classes (this 

will un-lock the plugin classes so that you can modify inheritance) 
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c. In the Plugins project, open the folder ‘DAQ’ 

d. Open the application and click the run button.  

e. Click Start to begin the acquisition. 

Note: this front panel has been designed to scale and resize all the controls appropriately.  This will be important 

when loading into a framework as a plugin with variable width and height parameters. To see how this has been 

configured, use the mouse to grab the bottom right corner and resize the panel. 

f. Click Pause to temporarily stop the acquisition.  

 

g. Click Stop to terminate execution of the VI. 

h. Switch to the block diagram to see how the application has been implemented.  A simple 

producer consumer pattern is used to dispatch commands from UI interaction to the consumer, 

which is a simple queued state machine that controls the DAQ task. 

3. Create an Object that will store and run this VI 

a. In the Project Explorer, navigate to the folder that contains the data acquisition application, 

which should be ‘Plugins > DAQ.’   

b. Right click on the folder and select ‘New > Class.’  When prompted, enter ‘DAQ Plugin’ as the 

name for the class.  Click OK and ‘DAQ Plugin.lvclass’ should now appear under the ‘DAQ’ folder 

in the Project Explorer. 

 

c. To function properly as a plugin, this class will need to inherit the capabilities of the Generic 

Plugin class that we looked at in section 1.  To specify this relationship, right click ‘DAQ 

Plugin.lvclass’ and select Properties as shown below. 
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d. In the Properties Dialog that appears for this class, select Inheritance from the list of Categories.  

On the right side of the screen, select Change Inheritance. 

 

e. The ‘Change Inheritance’ dialog will appear, which lists all of the Classes currently loaded in the 

Project Explorer.  Find and select ‘Generic Plugin’ and click Inherit from Selected. 
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f. The Change Inheritance dialog will close, returning to the Class Properties dialog.  Click OK to 

save the changes. 

g. Before proceeding, ensure that the new ‘DAQ Plugin.lvclass’ class has been saved to disk.  To do 

this, return to the Project Explorer and select File > Save All. 

h. When prompted, save the lvclass file in the same directory as the ‘Acquire Data.vi,’ which should 

be [root]\Plugins\DAQ, where [root] refers to the directory of the Project. DO NOT SAVE IT 

ANYWHERE ELSE AS THIS IS THE DIRECTORY THAT THE FRAMEWORK WIL LOOK IN 

i. Hold shift to select ‘Acquire Data.vi’ and ‘Acquire Enum States.ctl.’  Click and drag them under 

the ‘DAQ Plugin Class.lvclass’ file to make it a member of this class.  It should appear as shown 

below: 

 

j. Right-click on the Class and select ‘New > VI for Override.’  This will allow customization of 

behaviors that were defined by the parent ‘Generic Plugin.lvclass’ for the specific purpose of 

‘DAQ Plugin.lvclass’ class. 

k. We can override the behaviors of multiple methods, including ‘Run,’ ‘Stop,’ and ‘Configure,’ 

which allows us to completely customize what this plugin does for each.  In this example, we are 

going to customize the implementation of ‘Confiure Plugin.vi.’  Select ‘Configure Plugin.vi’ and 

select OK.   
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l. LabVIEW will generate a new VI named ‘Configure Plugin.vi.’  Switch to the block diagram and 

delete the subVI that appears (it’s the parent’s copy of Configure Plugin.vi). 

m. Open Quick-Drop by pressing CTRL + Space.  Type ‘Write UI Reference.vi.  This VI is the private 

data modifier that allows us to store a reference to the VI we want this plugin to run.  Drop it on 

the block diagram and connect it.  Finally, place ‘Static VI Reference’ from the application palette 

to build the block diagram shown below: 

 

n. In the Project Explorer, select ‘Acquire Data.vi,’ which is the VI we want this plugin to run.  Drag 

and drop it into the Static VI Reference.  
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o. The finished code should look like the diagram below:  

 

p. You can also modify the value of the string that will appear in the menu and in the header by 

modifying the code as shown: 

 

q. Return to the Project Explorer and click the ‘Save All’ button again. 

r. Open the Project, UI Plugin Framework.lvproj 

s. Open main.vi and run the application.  The menu should now be populated with one additional 

item to represent the newly created plugin.  Click on it and verify that it appears in the subpanel 

as shown below: 
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SENDING MESSAGES TO PLUGINS USING USER EVENTS 

GOAL 

We want to send basic commands to the plugin that are then handled in such a way to minimize the work being 

done in the background.  By doing so, we can ensure that the application continues to run smoothly as the user 

navigates between multiple objects. 

SCENARIO 

We want to configure the newly created Acquire Measurement.vi application to pause the acquisition and display 

when it is not being shown, or when a user opens the menu. 

DESCRIPTION 

Sending messages to plugins is a common challenge for plugins, as it represents a scenario in which you may need 

to broadcast the same information to N objects.  In this case, sending individual messages to every recipient is 

generally inefficient and difficult.  This exercise will use user events to broadcast information to plugins, who can 

then choose to act upon it as they see fit. 

CONCEPTS COVERED 

 Dynamic event registration 

 User APIs 
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1. Handle the user event ‘Menu Open,’ which should terminate execution of the plugin. 

a. Open the Plugin project and close the UI Plugin Framework Project 

b. In the Project Explorer for Plugins.lvproj, navigate to ‘Plugins > DAQ > Acquire Data.vi’ and open 

the block diagram. 

c. Right-click on the border of the event structure and select Show Dynamic Events Terminal, 

which will add the following input terminal to the structure: 

 

d. In the Project Explorer, navigate to ‘Parent Plugin Definition > Plugin Template > API’ and explore 

the folder.  

 

e. Initialize Plugin.vi will register all the necessary events that this plugin needs to respond to.  Place 

it on the block diagram of the plugin and connect it as shown: 
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f. Navigate to the case in the Event Structure that handles “System Pause Button”: Value Change.  

Note that this case currently handles the user pressing ‘Pause’ on the front panel. 

g. To add the user event to this case, right-click and select ‘Edit Events Handled by this Case” 

h. Click Add Event 

 

i. The middle list-box contains all the items that can serve as an event source.  The user events 

have been added to this list because of the inputs to the dynamic events terminal.  Note that 

there are multiple user events that we can chose from: 

 

j. Select ‘Menu Open Event’ and click OK. 

k. When the message that the menu is open is fired, this plugin now handles it by stopping the 

acquisition. 
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l. Make sure that the front-panel has been closed and return to main.vi.  Run the application and 

launch the plugin.  Show that opening the menu now pauses the acquisition. 
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OBJECT-ORIENTED HARDWARE ABSTRACTION LAYER 

GOAL 

Demonstrate the use of an object-oriented design pattern to abstract hardware in an instrument control 

application.  The goal of this abstraction is to make it simple to incorporate new hardware into an existing 

application without making modifications to the software framework. 

SCENARIO 

The problem with many test systems is that the overall system must be in operation longer than the 

individual system components are supported. Sometimes the device being tested has an active service 

life measured in decades, while many test instruments are obsolete and no longer supported after five 

years or less. Other times, the device being tested has an active service life measured in months. Both of 

these are examples of life-cycle mismatch. 

SETUP  

In order for all of the included instrument drivers to work, it’s important to ensure that you’ve downloaded and 

installed the correct instrument drivers. In LabVIEW, go to Help > Find Instrument Drivers and make sure the 

following appear in the list: 

 Fluke 884X Series 

 Tktds3xx 

 ag33xxx 

For the sake of this demo, it’s also important that it not have been run since the project was opened, as we will 

show the instrument drivers coming into memory for the first time using the VI Hierarchy Window.  Ensure that 

the class hierarchy appears as shown below before proceeding.  If it does not, simply close front panel of the top-

level VI and re-open it. 
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1. Provide a brief explanation of the application and how it works.  

a. Open the Project, ‘HAL.lvproj’ 

b. Expand the ‘Test Code’ folder and open the Main Test App.vi 

c. Expand the Device-Specific Software Plugin Class, DSSP.lvclass.  This is the parent for all device 

plugins and defines high-level generic functionality.  In this case, the only methods of this class 

are ‘Close Instrument’ and ‘Initialize Instrument.’ 

d. Right-click on ‘DSSP.lvclass’ and select ‘Show Class Hierarhcy.’  Prior to running the application, 

only one layer of children will be visible, as shown in the image. Keep this window open and 

carefully positioned so that it can be seen next to the front panel of Main Test App.vi.  If viewing 

on a projector with 1024 resolution, try to replicate the configuration shown below (taken on a 

monitor with 1024 x 768): 

 

e. Show the block diagram of the application to review the operations that this application will be 

conducting. 

f. The first VI is ‘Initialize All Devices.vi’ which is built on top of a factory design pattern that 

produces objects to represent the three devices based on the XML file that it is pointed to.  Open 

this VI and look at the block diagram. 

  



33 
 

g. This VI outputs four objects: one for a signal generator, one for a scope, one for a meter and 

finally one for a switch. The actual class that defines the various methods appropriate to each 

decide will be loaded at run-time in the four parallel factory design patterns.  The initialize 

instrument.vi will be dynamically dispatched based on the object that is loaded. 

 

h. Set a breakpoint just before the case structure of this block diagram.  This will make it easier to 

illustrate how and when the classes come into memory. 

i. Close (do not save) InitializeAllDevice.vi and return to the block diagram of the top-level VI. After 

the devices have all been initialized, they are then passed to other functions to complete the test 

sequence.  In this case, a frequency sweep (which utilizes both the signal generator and the 

scope), an LED test (which needs only the voltmeter) and then finally, the instruments are closed. 

j. Switch to the front panel and use the ring control to select ‘Simulated Instruments.xml’ and run 

the application (make sure the VI Hierarhcy window can be seen). 

k. When the execution reaches the breakpoint, turn on highlight execution, ensure you can see the 

class hierarchy and run the code.  The class hierarchy will populate the new objects as children of 

their generic parents as each factory pattern executes. 
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l. Repeat this process for the other enum operations.  The resultant class hierarchy will appear as 

shown: 
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MORE INFORMATION 

DOWNLOAD SOURCE CODE, MANUAL AND SLIDES  

 http://bit.ly/nV5GXD 

ONLINE RESOURCES 

 ni.com/largeapps – find best practices, online examples and a community of advanced LabVIEW users  

 ni.com/softwareengineering – download evaluation software and read more about the tools in this guide 

CUSTOMER EDUCATION CLASSES 

 Managing Software Engineering with LabVIEW 

o Learn to manage the development of a LabVIEW project from definition to deployment 

o Select and use appropriate tools and techniques to manage the development of a LabVIEW 

application 

o Recommended preparation for Certified LabVIEW Architect exam 

 Advanced Architectures in LabVIEW 

o Gain exposure to and experience with various architectures for medium to large LabVIEW 

applications 

o Learn how to select an appropriate architecture based on high-level requirements 

o Recommended preparation for Certified LabVIEW Architect exam 

 Object-Oriented Design and Programming in LabVIEW 

o Design an application using object-oriented design principles 

o Implement a basic class hierarchy using LabVIEW classes 

o Modify an existing LabVIEW application to replace common patterns with LabVIEW objects 

 


